v19 funktioniert nicht unter Windows7

Multi-Funktions-Werkzeug zur Verwaltung von Save.TV
by thomasfl
Fredel
Beiträge: 689
Registriert: So 21. Feb 2016, 20:45
bevorzugter Onlinevideorecorder: Save.TV

v19 funktioniert nicht unter Windows7

Beitrag von Fredel » Mi 19. Apr 2017, 19:29

Soeben Update auf 4.6.1 durchgeführt. PC Neustart. STVM startet normal.

Bei der Installation ist allerdings mein Virenscanner angesprungen. Was aber für solche private Entwicklungen nichts besonderes ist. Bei mir war dies zwar bei der Installation, aber ev. wurde ja auch eine Eurer Dateien vom Virenscanner nach dem auspacken geschluckt, bitte ggf. Log prüfen, oder eben Programmpfad:

Code: Alles auswählen

C:\Users\H56-9901-alpha>dir /b "C:\Program Files (x86)\STV MANAGER"
HtmlAgilityPack.dll
Newtonsoft.Json.dll
ObjectListView.dll
Renci.SshNet.dll
RestSharp.dll
STV MANAGER.application
STV MANAGER.exe
STV MANAGER.exe.config
STVM3.application
STVM3.exe
STVM3.exe.config
TMDbLib.dll
TVDB.dll
TvdbLib.dll
unins000.dat
unins000.exe


jDownloader & Save.TV: 1. Schritte - automatischer Download <--> Save.TV Manager Version 3 Update: Favoriten retten

Link:
BBcode:
HTML:
Hide post links
Show post links

thomasfl
STV MANAGER
STV MANAGER
Beiträge: 295
Registriert: Fr 4. Mär 2016, 11:54

v19 funktioniert nicht unter Windows7

Beitrag von thomasfl » Mi 19. Apr 2017, 20:11

Fredel hat geschrieben:
Mi 19. Apr 2017, 19:29
Bei der Installation ist allerdings mein Virenscanner angesprungen. Was aber für solche private Entwicklungen nichts besonderes ist.
Das finde ich jetzt aber schon etwas beunruhigend. Was hat Dein Scanner denn gefunden??
Bild STV MANAGER - Tool zur Verwaltung von Save.TV --- Neuigkeiten & Downloads --- Fragen & Support

Link:
BBcode:
HTML:
Hide post links
Show post links

Benutzeravatar
sv00010
Beiträge: 270
Registriert: Sa 20. Feb 2016, 16:41
bevorzugter Onlinevideorecorder: onlinetvrecorder.com
Kontaktdaten:

v19 funktioniert nicht unter Windows7

Beitrag von sv00010 » Mi 19. Apr 2017, 20:19

Ich habe in der Zwischenzeit mal herum experimentiert.
Der Fehler beim Starten des Programmes liegt meiner Meinung nach daran, dass der Ordner mit der Einstellungen des Programms fehlt.
Das habe ich über eine Fehlermeldung herausgefunden.

Fehlermeldung_debug_V19.png
Fehlermeldung_debug_V19.png (9.39 KiB) 325 mal betrachtet

Ich habe den fehlenden Ordner dann selber erstellt und dann hat es funktioniert.

Ordner_selber_erstellen.png
Ordner_selber_erstellen.png (23.86 KiB) 325 mal betrachtet

Dazu muss man allerdings in der Systemsteuerung unter Ordneroptionen

Systemsteuerung_Ordneroptionen.png
Systemsteuerung_Ordneroptionen.png (76.78 KiB) 325 mal betrachtet

im Reiter Ansicht Ausgeblendeten Dateien, Ordner und Laufwerke anzeigen lassen.

Ordneroptionen.png
Ordneroptionen.png (24.37 KiB) 325 mal betrachtet
Verstecken ist aktiviert
Um diesen versteckten Text lesen zu können, mußt du registriert und angemeldet sein.

Link:
BBcode:
HTML:
Hide post links
Show post links

thomasfl
STV MANAGER
STV MANAGER
Beiträge: 295
Registriert: Fr 4. Mär 2016, 11:54

v19 funktioniert nicht unter Windows7

Beitrag von thomasfl » Mi 19. Apr 2017, 20:21

Ich habe den Bug gefunden. Die App versucht, in den AppData Ordner zu schreiben, bevor das Verzeichnis angelegt wird. Daher tritt dieser Fehler nur auf, wenn die App komplett jungfräulich installiert wurde.

Ich stelle später ein Bugfix auf die v20 online. Bis dahin gibt es die oben beschriebene einfache Lösung: bitte manuell das Verzeichnis C:\Users\(Username)\AppData\Roaming\STVM anlegen.
Bild STV MANAGER - Tool zur Verwaltung von Save.TV --- Neuigkeiten & Downloads --- Fragen & Support

Link:
BBcode:
HTML:
Hide post links
Show post links

thomasfl
STV MANAGER
STV MANAGER
Beiträge: 295
Registriert: Fr 4. Mär 2016, 11:54

v19 funktioniert nicht unter Windows7

Beitrag von thomasfl » Mi 19. Apr 2017, 21:22

v20 ist verfügbar. Der Fehler ist behoben.
Bild STV MANAGER - Tool zur Verwaltung von Save.TV --- Neuigkeiten & Downloads --- Fragen & Support

Link:
BBcode:
HTML:
Hide post links
Show post links

Fredel
Beiträge: 689
Registriert: So 21. Feb 2016, 20:45
bevorzugter Onlinevideorecorder: Save.TV

v19 funktioniert nicht unter Windows7

Beitrag von Fredel » Do 20. Apr 2017, 19:47

thomasfl hat geschrieben:
Mi 19. Apr 2017, 20:11
Was hat Dein Scanner denn gefunden??
w32/exploit.gen

Datei einfach manuell scannen, oder zu einem Analyseportale des Vertrauens hochladen. Der Echtzeit Schutz ist immer etwas voreilig und das ist auch gut so.
jDownloader & Save.TV: 1. Schritte - automatischer Download <--> Save.TV Manager Version 3 Update: Favoriten retten

Link:
BBcode:
HTML:
Hide post links
Show post links

andi112
Beiträge: 151
Registriert: Fr 26. Feb 2016, 20:32

v19 funktioniert nicht unter Windows7

Beitrag von andi112 » Do 20. Apr 2017, 21:46

Habe .NETFramework 4.5.2. Wie muss man jetzt exakt vorgehen, um die v20 zu installieren, wenn vorher die v19 zwar installiert wurde, aber nicht lief?

Link:
BBcode:
HTML:
Hide post links
Show post links

Benutzeravatar
sv00010
Beiträge: 270
Registriert: Sa 20. Feb 2016, 16:41
bevorzugter Onlinevideorecorder: onlinetvrecorder.com
Kontaktdaten:

v19 funktioniert nicht unter Windows7

Beitrag von sv00010 » Do 20. Apr 2017, 21:51

andi112 hat geschrieben:
Do 20. Apr 2017, 21:46
Habe .NETFramework 4.5.2. Wie muss man jetzt exakt vorgehen, um die v20 zu installieren, wenn vorher die v19 zwar installiert wurde, aber nicht lief?
Es lag doch nicht am Framework, sondern am fehlenden Ordner.
Das wurde jetzt in der Version 20 korrigiert.
Du kannst es ganz normal installieren.
Verstecken ist aktiviert
Um diesen versteckten Text lesen zu können, mußt du registriert und angemeldet sein.

Link:
BBcode:
HTML:
Hide post links
Show post links

thomasfl
STV MANAGER
STV MANAGER
Beiträge: 295
Registriert: Fr 4. Mär 2016, 11:54

v19 funktioniert nicht unter Windows7

Beitrag von thomasfl » Do 20. Apr 2017, 21:58

Yep, einfach drüber installieren.
Bild STV MANAGER - Tool zur Verwaltung von Save.TV --- Neuigkeiten & Downloads --- Fragen & Support

Link:
BBcode:
HTML:
Hide post links
Show post links

andi112
Beiträge: 151
Registriert: Fr 26. Feb 2016, 20:32

v19 funktioniert nicht unter Windows7

Beitrag von andi112 » Do 27. Apr 2017, 12:28

Ja, jetzt funktioniert es.

Link:
BBcode:
HTML:
Hide post links
Show post links

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast