Download Manager Synology 7.0 und STV

Multi-Funktions-Werkzeug zur Verwaltung von Save.TV
by thomasfl
Area66
Beiträge: 2
Registriert: Mo 16. Aug 2021, 19:21

Download Manager Synology 7.0 und STV

Beitrag von Area66 » Mo 23. Aug 2021, 16:41

Kann seit geraumer Zeit an keiner meiner Synologys etwas per STV downloaden.
Die Fehlermeldung lautet:

Login nicht erfolgreich...
im Loging: Synology: {"error":{"code":103},"success":false}

Kann es sein, dass die API in DSM geändert wurde...?

Zeiltich kann ich es nicht genau nachvollziehen, aber sollte seit update der DSM auf 7.0 so sein...



Link:
BBcode:
HTML:
Hide post links
Show post links

thomasfl
STV MANAGER
STV MANAGER
Beiträge: 416
Registriert: Fr 4. Mär 2016, 11:54

Download Manager Synology 7.0 und STV

Beitrag von thomasfl » Mo 23. Aug 2021, 20:03

Hi,

Habe erst seit einer Woche eine neue 220+ mit DSM 7 laufen, meine alte 213+ wurde vom neuen System nicht mehr supported. Naja, aber acht Jahre Updates, das bietet selbst Apple nicht ;)

Wenn ich alles laufen habe kann ich mal schauen. iCh bin aber nicht sicher, ob ich den STVM noch kompiliert bekomme, ich war ewig nicht mehr dran …
Bild STV MANAGER - Tool zur Verwaltung von Save.TV --- Neuigkeiten & Downloads --- Fragen & Support

Link:
BBcode:
HTML:
Hide post links
Show post links

thomasfl
STV MANAGER
STV MANAGER
Beiträge: 416
Registriert: Fr 4. Mär 2016, 11:54

Download Manager Synology 7.0 und STV

Beitrag von thomasfl » Mo 23. Aug 2021, 20:05

Ah, bist Du sicher, dass Du Dich in der Download Station vorher mindestens einmal mit dem User eingeloggt hast? Beim ersten Login werden offensichtlich irgendwelche Settings gesetzt, sonst funzt die API nicht.
Bild STV MANAGER - Tool zur Verwaltung von Save.TV --- Neuigkeiten & Downloads --- Fragen & Support

Link:
BBcode:
HTML:
Hide post links
Show post links

Area66
Beiträge: 2
Registriert: Mo 16. Aug 2021, 19:21

Download Manager Synology 7.0 und STV

Beitrag von Area66 » Di 24. Aug 2021, 09:25

thomasfl hat geschrieben: Mo 23. Aug 2021, 20:05 Ah, bist Du sicher, dass Du Dich in der Download Station vorher mindestens einmal mit dem User eingeloggt hast? Beim ersten Login werden offensichtlich irgendwelche Settings gesetzt, sonst funzt die API nicht.
absolut... mit mehreren Usern getestet...
Witzigerweise bekomm ich bei https den Error 103.. bei http oftmals gar keinen Fehler. Es geht einfach nur nicht...

Der NAS Download Manager (Chrome Extension) funktioniert dagegen einwandfrei...

Link:
BBcode:
HTML:
Hide post links
Show post links

Benutzeravatar
sv00010
Beiträge: 688
Registriert: Sa 20. Feb 2016, 16:41
bevorzugter Onlinevideorecorder: onlinetvrecorder.com

Download Manager Synology 7.0 und STV

Beitrag von sv00010 » Di 24. Aug 2021, 21:06

Area66 hat geschrieben: Di 24. Aug 2021, 09:25 Witzigerweise bekomm ich bei https den Error 103.. bei http oftmals gar keinen Fehler. Es geht einfach nur nicht...
Ich hatte da auch mal Probleme mit https.
Dann hatte ich das ganze Projekt auf .net Framework 4.6.x hochgesetzt und den Code aus dem Thread eingebaut.
https://stackoverflow.com/questions/349 ... 1/45692875

Ich an seiner Stelle, würde das ganze Projekt auf eine höhere Frameworkversion ändern, einfach versuchen irgendwie den Code einzubauen und hoffen dass es wieder funktioniert.

Am besten wäre es gleich auf das Framework 4.8 zu kompilieren und auch gleich noch die TLS1.3 mit einzubauen.
https://docs.microsoft.com/de-de/dotnet ... mework-4.8


Es könnte allerdings auch daran liegen, dass es zurzeit wieder Probleme mit Save.TV gibt
viewtopic.php?f=70&p=7225#p7225

Link:
BBcode:
HTML:
Hide post links
Show post links

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast